Tuesday, December 3, 2013

Installation of application MAXIMO failed.

Problem:
I changed some class files to alter the functionality of Maximo. I did a rebuild of the ear file. I 'Uninstalled' the MAXIMO application from websphere.

I Installed MAXIMO again, but the serer did not respond. So i should have waited, but I started a new install of MAXIMO. Now the system is giving met the following error:

"A composition unit with name MAXIMO already exists. Select a different application name.

ADMA5011I: The cleanup of the temp directory for application MAXIMO is complete


ADMA5014E: The installation of application MAXIMO failed.





Used environment: 
Windows 2008 r2 server, 64 bit
Websphere 7.0.0.15
Maximo 7.5.0.5


The Solution:
(Note that all paths mentioned below could be different on your system depending the path where you installed Websphere)

  • Stop the MXServer


  • Stop the Maximo services;
    • IBMWAS70Service - ctgCellManager01
    • IBMWAS70Service - nodeagent


  • Deleted the "MAXIMO" Directory deleted from:
    • D:\IBM\WebSphere\AppServer\profiles\ctgDmgr01\config\cells\ctgCell01\blas
    • D:\IBM\WebSphere\AppServer\profiles\ctgDmgr01\config\cells\ctgCell01\cus


  • Delete the "MAXIMO.ear" from:
    • D:\IBM\WebSphere\AppServer\profiles\ctgAppSrv01\config\cells\ctgCell01\applications
    • D:\IBM\WebSphere\AppServer\profiles\ctgDmgr01\config\cells\ctgCell01\applications


  • Delete all files in the following directories:
    • D:\IBM\WebSphere\AppServer\profiles\ctgAppSrv01\temp
    • D:\IBM\WebSphere\AppServer\profiles\ctgAppSrv01\wstemp
    • D:\IBM\WebSphere\AppServer\profiles\ctgAppSrv01\config\temp
    • D:\IBM\WebSphere\AppServer\profiles\ctgDmgr01\temp
    • D:\IBM\WebSphere\AppServer\profiles\ctgDmgr01\wstemp
    • D:\IBM\WebSphere\AppServer\profiles\ctgDmgr01\config\temp
  • Start the Maximo services;
    • IBMWAS70Service - ctgCellManager01
    • IBMWAS70Service - nodeagent

  • Install MAXIMO, all should go well now.